Etrieve Down
Incident Report for Okanagan College - IT
Resolved
Etrieve has returned to normal service. The vendor's cloud team has resolved the issue.
Posted Mar 20, 2024 - 08:53 PDT
Investigating
Etrieve is currently down. We have engaged the vendor and are currently investigating the issue.
Posted Mar 20, 2024 - 07:27 PDT
This incident affected: Etrieve Central (Softdocs).