Cloud printing
Incident Report for Okanagan College - IT
Resolved
Resolved
Posted Mar 26, 2024 - 10:19 PDT
Investigating
We are currently investigating reports of Cloud printing not responding.
Posted Mar 26, 2024 - 09:47 PDT
This incident affected: Printing.