Etrieve Unavailable
Incident Report for Okanagan College - IT
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 11:44 PST
Investigating
Etrieve Central is unavailable, we are investigating the issue.
Posted Feb 01, 2023 - 10:42 PST
This incident affected: Etrieve Central (Softdocs).