Ricoh printers-scanning and photocopying services unavailable.

Incident Report for Okanagan College - IT

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 09:21 PDT

Identified

The Ricoh printers' scanning and photocopying services are currently unavailable. Our network team is actively working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Mar 28, 2025 - 16:02 PDT
This incident affected: Printing.