Incident Notice: Kaltura Access Issues for Some Rogers Customers

Incident Report for Okanagan College - IT

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 12:33 PST

Identified

Some users on Rogers home internet networks are currently experiencing issues accessing Kaltura. Our network teams are actively working with Rogers to investigate and troubleshoot the problem.

Further updates will be provided as more information becomes available. We appreciate your patience and understanding.
Posted Jan 20, 2026 - 10:37 PST
This incident affected: myMoodle.