Microsoft 365 Service Issue

Incident Report for Okanagan College - IT

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 09:30 PDT

Identified

We’re aware of a potential issue affecting Microsoft 365 services (including Outlook, Teams, OneDrive, and other M365 apps). Microsoft is currently investigating the problem.

You may experience slow performance or trouble accessing some Microsoft 365 tools.

We’ll share more information as soon as Microsoft provides an update — expected within the next 30 minutes.

Thank you for your patience.
Posted Oct 29, 2025 - 09:33 PDT
This incident affected: Email systems and Sharepoint/OneDrive.