Digital Forms (Etrieve) Unavailable

Incident Report for Okanagan College - IT

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 15:32 PDT

Identified

IT Services has identified and issue with the Digital Forms (Etrieve) system and is currently investigating the problem. Users trying to access Etrieve will be unable to do so.
Our team is working diligently to trace the issue and restore services. We have contacted the Etrieve service provider and engaged their technical support team.

We appreciate your patience,
IT Services
Posted Apr 24, 2026 - 14:12 PDT
This incident affected: Etrieve Central (Softdocs).