Etrieve Insecure Domain Warning
Incident Report for Okanagan College - IT
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 09:04 PST
Monitoring
Our Service provider's domain, etrieve.cloud, has been incorrectly flagged by Google as an insecure domain and is causing our sites to be marked with a warning when using Chrome and, in some cases, Safari or Firefox. SoftDocs have verified the etrieve sites are secure and are working with Google to resolve the issue.

In the meantime, you can use New Edge browser to allow access to the sites without any issues OR you can proceed through the warning message in Chrome/Safari/Firefox by clicking “Details” and then “Visit this site”. We will continue to monitor the situation and keep you informed of any changes
Posted Jan 13, 2021 - 09:47 PST
This incident affected: Etrieve Central (Softdocs).