Some users may experience delays or be unable to load the Submissions tab in Etrieve.

Incident Report for Okanagan College - IT

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 07:50 PST

Monitoring

The vendor has implemented a fix and we are monitoring the results.
Posted Jan 13, 2026 - 06:21 PST

Investigating

Some users may experience delays or be unable to load the Submissions tab in Etrieve.
We have contacted the vendor and will share updates as more information becomes available.
Thank you for your patience.
Posted Jan 05, 2026 - 09:42 PST
This incident affected: Etrieve Central (Softdocs).